Cisco 7206 BRAS (pppoe server) + nat

 

Building configuration...

Current configuration : 5209 bytes
!
! Last configuration change at 10:05:33 IRI Sun Jan 2 2000 by admin
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname Cisco-7206
!
boot-start-marker
boot-end-marker
!
security passwords min-length 1
no logging monitor
enable secret 5 **********
!
aaa new-model
!
!
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa authorization subscriber-service default local group radius
aaa accounting delay-start
aaa accounting update periodic 1
aaa accounting network default
action-type start-stop
group radius
!
aaa accounting network default
action-type start-stop
group radius
!
!
aaa nas port extended
!
!
!
aaa server radius dynamic-author
client 192.168.1.2 server-key 7 *********
auth-type any
ignore session-key
ignore server-key
!
aaa session-id unique
clock timezone IRI 3 30
clock summer-time IRI recurring
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip domain name msadighian.com
ip name-server 8.8.8.8
ip multicast-routing
ip accounting-threshold 200000
no ipv6 cef
!
!
subscriber authorization enable
mpls label protocol ldp
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
!
!
!
archive
log config
logging enable
notify syslog contenttype plaintext
username admin password 7 **********
!
!
bridge irb
!
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 30000
sessions per-vlan limit 30000
sessions auto cleanup
!
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat outside
media-type rj45
speed auto
duplex auto
negotiation auto
!
interface FastEthernet0/2
no ip address
shutdown
speed auto
duplex auto
!
interface GigabitEthernet0/2
no ip address
media-type rj45
speed auto
duplex auto
negotiation auto
pppoe enable group global
!
interface GigabitEthernet0/3
no ip address
shutdown
media-type rj45
speed auto
duplex auto
negotiation auto
!
interface Virtual-Template1
mtu 1460
ip unnumbered GigabitEthernet0/1
ip nat inside
ip tcp adjust-mss 1320
no logging event link-status
peer default ip address pool DefaultPool
ppp encrypt mppe auto
ppp authentication chap pap default
ppp authorization default
ppp accounting default
!
ip local pool DefaultPool 10.0.0.1 10.0.0.254
ip default-gateway 192.168.1.254
ip nat pool p1 192.168.1.1 192.168.1.1 netmask 255.255.255.252
ip nat inside source list 10 interface GigabitEthernet0/1 overload
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip radius source-interface GigabitEthernet0/1
access-list 10 permit 10.0.0.0 0.0.0.255
no cdp run
!
!
radius-server attribute 44 include-in-access-req
radius-server attribute 8 include-in-access-req
radius-server attribute 31 mac format ietf
radius-server host 192.168.1.2 auth-port 1812 acct-port 1813
radius-server source-ports extended
radius-server retransmit 2
radius-server timeout 3
radius-server unique-ident 20
radius-server key 7 ********
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 5 15
!
end

By: Mehdi Sadighian
Contact: mehdi.sadighian@hotmail.com
TAG: cisco,7200,7206,bba-group,vpdn,pppoe server,bras