cisco 3660: traffic shaping per ip address

class-map match-all mehdi2
match access-group name mehdi2
class-map match-any mehdi
match access-group name mehdi
!
!
policy-map lan
class mehdi
police cir 160000
exceed-action drop
class mehdi2
shape peak 2048000
!
interface FastEthernet0/0
ip address 192.168.102.1 255.255.255.0
ip nat inside
service-policy output lan
duplex auto
speed auto
!

ip access-list extended mehdi
permit ip any host 192.168.102.2
ip access-list extended mehdi2
permit ip any host 192.168.102.21

By: Mehdi Sadighian
Contact: mehdi.sadighian@hotmail.com
TAG: cisco,3660,bandwidth management, rate limit,per IP address, per host