Current configuration : 1569 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret  XXXX
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
!
username admin password XXXXXXXX
!
archive
log config
hidekeys
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto
!
!
bridge irb
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/37
cbr 2048
encapsulation aal5snap
!
bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.x.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI1
ip address y.y.y.y 255.255.255.248
ip nat outside
ip virtual-reassembly
!
ip default-gateway x.x.x.x
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
no ip http server
no ip http secure-server
ip nat pool p1 y.y.y.y     y.y.y.y netmask 255.255.255.0
ip nat inside source list 1 pool p1
ip nat inside source list 10 pool p1 overload

!
access-list 10 permit 192.168.x.0 0.0.0.255
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
login local
no modem enable
line aux 0
login local
line vty 0 4
login local
!
scheduler max-task-time 5000
end

By: Mehdi Sadighian
Contact: mehdi.sadighian@hotmail.com
TAG: cisco,878,mpls,nat,atm,bvi,bridge